转码器

“转码器”帮助目录

转码器可将文件从 ANSI，OEM 或其他类型的代码页转换成 Unicode。也可以使用“转换”菜单显示出对话框，以指定转换选项。Windows NT 4.0 中文版的转码器还提供了繁体中文和简体中文之间的转换。

使用转码器：

  1. 选取“文件”菜单的“打开源文件”，指定您要转换的文件。
  2. 选取“转换”菜单的“改变源文件选项”命令。
  3. 在对话框中选取源文件所使用的代码类型。
  4. 选取“转换”菜单的“改变目的文件选项”命令。
  5. 在对话框中选取目标文件所使用的代码类型。
  6. 选取“转换”菜单的“立即转换”命令。
  7. 在“另存为”的对话框中，指定目的文件的文件名。

请参阅

剪贴板支持
字节顺序
查看源/目的文件


剪贴板支持

转码器可以接受剪贴板的文字作为来源数据。也可以将目的数据复制回剪贴板。使用“编辑”菜单或传统的快捷键来实现。

Windows 系统会根据使用的字符编码而自动标明剪贴板文字数据。


字节顺序

读取来源文件时，转码器会查找 Unicode 的字节顺序标记。如果在文件的开头找到此特别的双字节顺序，则它会假设以下的文字为宽字符的顺序。转码器也会查找 Unicode 的反转字节顺序标记。在此情况下，它也会将它假设为 Unicode 文字，但是它会自动切换每个宽字符的低和高字节。

任何时候，用户都可使用 “转换”菜单下的“对调源文件字节顺序”或“对调目的文件字节顺序”菜单项目，来更改来源文件或目的文件的字节顺序。如果做这个动作，则主窗口会显示对调高低位顺序。

字节顺序只有在以不同的 endian 模式运行的系统中移动时才显重要。例如，Intel 的处理器都运行 little endian，而 Motorola 的处理器则运行 big endian。Windows NT 4.0 只在 little endian 处理器上运行。然而，Unicode 在各种不同的系统上都得到支持。


(Untitled)

转换选项

转换 MultiByteToWideChar 时：

指定 MB_PRECOMPOSED 时，程序会使用组成（precomposed）字符 ─ 也就是基本（base）字符和非间隔（nonspacing）字符具有相同字符值的字符。这是默认的解译选项。

指定 MB_COMPOSITE 时，程序会使用混合（composite）字符 ─ 也就是基本字符和非间隔字符具有不同值的字符。

指定 MB_USEGLYPHCHARS 时，程序会使用 glyph 字符代替控制字符。

(基本字符就是非间隔字符之前的字符。例如，在标上重音的 e 字中，e 为基本字符，重音符号则为非间隔字符。)

转换 WideCharToMultiByte ê±￡o

指定 WC_COMPOSITECHECK 时，程序会将混合字符转换为组成字符。在混合字符中，基本字符和对应的非间隔字符具有不同的字符值。在组成字符中，基本字符和对应的非间隔字符具有相同的字符值。

当应用程序指定 WC_COMPOSITECHECK 时，它会耕具下列标记自行转换为组成字符。如果宽字符（wide-character）字串中没有基本/非间隔字符组合的组成映射，则此项功能会取决于这些标志。

WC_DISCARDNS去掉非间隔字符。
WC_SEPCHARS产生单独字符。这是默认的做法。
WC_DEFAULTCHAR以默认字符替换例外情形。


查看文字数据

查看源/目的文件

转码器的主窗口中有两个按钮，可以让用户查看来源文件或目的文件的文字数据。查看本文数据时，必须有可提供 glyph 以便在本文中显示字符的字体。转码器将从目前安装在系统中的字体中选择一种适合的字体。然而转码器可处理比一般字体安装更多的代码页。在此情况下，字体系统将尽可能提供最适合的字体，而且字体所没有支持的字符也将利用特殊默认字符显示出来。对大多数字体而言，此默认字符是一个方块。

Windows NT 4.0 中有一套称为 Lucida Sans Unicode 的特殊字体，放在 L_10646.ttf 文件中。利用控制面板安装此字体后，用户想查看 Unicode 数据时就可以看到更多字符了。


(Untitled)

安装转换表

转码器也能让您安装其他的转换表，不需使用 REGEDT32.EXE。其方法为选取“转换”菜单的“安装新的转换表”，并选取“转换表”对话框中的“新增”按钮，这样就可以选取其他的 .NLS 文件新增到转换列表中。.NLS 文件是 Windows NT 所提供的，保存于 SystemRoot\SYSTEM32 目录下。