Viewing text data

檢視文字資料

轉碼器程式的主要視窗中有兩個按鈕，可以讓使用者檢視來源檔或目的檔的文字資料。檢視本文資料時，必須有可提供 glyph 以便在本文中顯示字元的字型。轉碼器程式將從目前安裝於系統中的字型中，選擇一個適合的字型。然而，轉碼器程式可處理比一般字型安裝更大組的 code page。在此情況下，字型系統將儘可能提供最適合的字型，而且字型所沒有支援的字元也將利用特殊預設字元顯示出來。對大多數字型而言，此預設字元是一個方塊。


Byte order

位元組順序

讀取來源檔時，轉碼器程式會尋找特別的記號，代表 Unicode 的位元組順序標記。如果在檔案的開頭找到此特別的雙位元組順序，則它會假設以下的文字為寬字元的順序。轉碼器程式也會尋找 Unicode 的反轉位元組順序標記。在此情況下，它也會將它假設為 Unicode 文字，但是它會自動切換每個寬字元的低和高位元組。

任何時候，使用者皆可使用「轉換」功能表下的「對調來源/目的高低位元組」功能表項目，來更改來源檔或目的檔的位元組順序。如果做這個動作，則主要視窗會顯示對調高低位元組。

位元組順序只有在以不同的 endian 模式執行的系統中移動時才顯重要。例如，Intel 的處理器都執行 little endian，而 Motorola 的處理器則執行 big endian。Windows NT 3.1 版只在 little endian 處理器上執行。然而，Unicode 在各種不同的系統上都得到支援。


Uconvert

轉碼器 -- 轉換成 Unicode 文字 / 從 Unicode 文字轉換

轉碼器可將檔案從 ANSI，OEM 或其他類型的字碼頁轉換成 Unicode，或從 Unicode 轉換成其他類型的字碼頁。您可以使用「轉換」功能表顯示對話方塊，來指定轉換選項。

使用轉碼器程式：

1選取「檔案」功能表的「開啟來源檔」，指定您要轉換的檔案。

2選取「轉換」功能表的「變更來源選項...」/「變更目的選項...」。

3選取「轉換」功能表的「立即轉換」。

4在「另存新檔」的對話方塊中，指定已轉換檔案的檔名。

其他相關資訊：

剪貼板支援

轉換選項

位元組順序

檢視文字資料


Conversion options

轉換選項

來源選項...

有 Unicode、BIG 5、通用碼 (CNS11643)、公會碼 (TCA)、倚天碼 (ETEN)、IBM PS55、電信碼 (TELEgraph)、王安碼等選項。

目的選項...

有 Unicode、BIG 5、通用碼 (CNS11643)、公會碼 (TCA)、倚天碼 (ETEN)、IBM PS55、電信碼 (TELEgraph)、王安碼等選項。

在轉換字元時，來源選項和目的選項不可相同。


Clipboard support

剪貼板支援

轉碼器程式可以接受剪貼板的文字作為來源資料，也可以將目的資料複製回剪貼板。這些功能可以經由功能表上的「編輯」功能表，或利用其對應的快速鍵來執行。系統會根據使用的字碼頁而自動標明剪貼板文字資料。