概述

用户只要提供标准格式的输入法码表原文件，通过 Windows 2000 内置的输入法生成器，即可生成完全具有 Windows 2000 特性和功能的中文输入法，极大丰富了用户的输入手段。

输入法生成器可以生成满足以下条件的中文输入法：

  • 码元集合是键盘可键入键（共 47 键）的子集；
  • 输入法的最大编码长度为 12；
  • 信息元为单符或多符代码的形码或音码。
码表原文件是一个扩展名 .TXT 的文本文件，它包含了目标输入法全部的特征信息和编码规则信息，是对目标输入法的完整描述。


运行输入法生成器

操作步骤

  • 运行“Windows资源管理器”
  • 浏览目录“C:\WINNT\SYSTEM32\DLLCACHE ”
  • 在上述目录下运行“imegen.exe”

注

假设: Windows 2000 安装在 C:\WINNT下。


码表原文件格式

  • [Description]区段
    该区段描述了目标输入法的基本属性，包括六个入口：

  • [Rule]区段

    该区段描述了目标输入法的构词规则。构词规则是由若干构词规则表达式组成，下面给出构词规则表达式的定义：

    c[逻辑符][词语长度]= {[序号标识][汉字序号][取码序号]+ {[序号标识][汉字序号][取码序号]+ {[序号标识][汉字序号][取码序号]+...}}}
    说明：

    实例：
    ce2=p11+p12+p21+p22 表示二字词，取第一字的第一、二码，第二字的第一、二码。

    ce2=cp10+cp20 表示二字词，取第一字的所有码和第二字的所有码。

    ca4=p11=p21=p31=n11 表示四字以及四字以上的词，取第一字的第一码，第二字的第一码，第三字的第一码，和倒数第一字的第一码。

  • 码表实例

    [Description]

    Name=郑码

    MaxCodes=4

    MaxElement=2

    UsedCodes=abcdefghijklmnopqrstuvwxyz

    WildChar=?

    NumRules=3

    [Rule]

    ce2=p11+p12+p21+p22
    ce3=p11+p21+p32+p31
    ca4=p11+p21+p31+p41
    [Text]

    一a av
    一下aa
    可歌可泣aaav
    无可奉告aacm
    一开始aaez
    一天天aaga
    无可奈何aagn

    提示：

    码表原文件可以只有[Text]区段，[Description] 和 [Rule]可以省略，留待创建输入法时填写。


转换码表原文件

在创建输入法之前必须先将码表原文件转换成输入法识别的 .MB 目标文件。

操作步骤
  • 双击“附件”中的“输入法生成器”。
  • 选择“创建输入法”标签，单击“浏览”，选一个码表源文件。
  • 单击“转换”按钮。


创建输入法

生成码表原文件即可创建输入法。

生成目标输入法后，系统将提示用户“是否安装输入法”。选择“是”，系统将自动安装该输入法。此时该输入法就成为系统内置输入法的一员了，具有 Windows 2000 特性和功能的输入法。

操作步骤

  • 双击“附件”中的“输入法生成器”。
  • 选择“创建输入法”标签，单击“浏览”，选一个码表源文件，其基本格式为：

    [汉字][编码] [构词码]

    [汉字]与[编码]之间无空格，[编码]与[构词码]之间有一空格，[构词码]可以为空。

  • 填写其它输入法编码信息。
  • 也可以自己定义构词规则，例如：

    ca4=P11+P21+p31+P42

    该表达式表示词长度大于等于 4 的词语编码规则为：

    对于没有构词码的字，取其编码。
  • 单击“创建”按钮。
  • 填入输入法信息，然后单击“确定”，即生成输入法文件（.IME 文件）和码表文件（.MB 文件）。

  • 新生成的输入法即可添加到系统中，和其它预装的输入法一样使用。


逆转换

如果用户已有码表文件（．MB 文件），可以通过“逆转换”功能，生成码表源文件（．TXT文件），以便于用户浏览和进行编辑操作。

操作步骤
  • 双击“附件”中的“输入法生成器”。
  • 选择“逆转换”标签，单击“打开文件”，选一个码表文件，然后单击“确定”返回。
  • 在“逆转换”任务中单击“逆转换”，即可进行转换。
  • 转换完成，单击“确定”后返回。


词条排序

如果用户已有码表源文件（．TXT 文件），可以通过“词条排序”功能，重新生成按编码规则排序的码表源文件（．TXT文件），以便于用户浏览和进行编辑操作。

操作步骤

  • 单击“附件”中的“输入法生成器”。
  • 选择“词条排序”标签，单击“打开文件”，选一个码表源文件，然后单击“确定”返回。
  • 在“词条排序”任务中单击“排序”，即可进行排序。
  • 排序完成，单击“确定”后返回。


批量造词

用户通过批量造词可以对某一目标输入法的词库文件进行插入词组，删除等操作。

操作步骤
    单击“附件”中的“输入法生成器”。
  • 选择“批量造词”标签，单击“打开文件”，选一个词库码表源文件，然后单击“确定”返回。
  • 在“批量造词”任务中单击“全选”。
  • 在“批量造词”任务中单击“插入词组”，即可进行插入词组操作。
  • 在“批量造词”任务中单击“用户词库”窗口，即可进行用户词库的全选、自动编码、删除、存盘等操作。
  • 批量造词完成，单击“关闭”后返回。

词库文件

在批量造词中，您可以导入一个词库文件，输入法生成器将自动把词库中的新词加入到您指定的输入法的词库文件中去。

词库文件格式
  • 纯文本文件
  • 每一个词条占用一行
  • 词条后可以不给出相应的拼音，如果要给出，请连续排放。词条与拼音之间，以及拼音与拼音之间不加空格。
文件格式举例
  • 不带拼音
    ...
    ...
    美好的未来
    软件产业
    共同发展
    常用的词组
    ...
    ...

  • 带拼音
    ...
    ...
    美好的未来meihaodeweilai
    共同发展gongtongfazhan
    软件产业ruanjianchanye
    常用的词组changyongdecizu
    ...


版本信息

用户通过版本信息查看有关“输入法生成器”的信息。

操作步骤

  • 单击“附件”中的“输入法生成器”。

  • 选择“版本信息”标签，即可弹出输入法生成器版本信息。
  • 查看完毕，单击“关闭”返回。