概述

根据汉字的形态信息，赋予每个字或词一个代码，称为汉字的字形编码，简称形码。 《郑码》是一种形码，编码方法的基本原理是：

  • 把方块汉字看作由构字单元组合而成，基础的构字单元是字根，最小构字单元是笔画。
      • 举例：
    • “艮、卩、鱼、口”４个字根可以合成“即、鲫、唧”等 3 个字根，

    • 字根“木、曰”和笔画“ [image] ”可合成“札、电” 2 个字
  • 字根排列的先后顺序叫根顺，根顺与书写顺序一致。
  • 按逆过程可以把汉字分解成字根和笔画，按根顺依次排列后，代入字根和笔画的代码，就能得出汉字的编码。将编码输入计算机，通过机内码转换，汉字信息便存贮在计算机里。
      • 举例：
    • 鲫 --- 鱼\ R 艮\ X 卩\ Y --- RXY

    • 电 --- 曰\ K [image] \ Z --- KZ
《郑码》利用字形信息编码，确立了“笔画－字根－整字－词语”这样一个检索序列。就是说，用几种笔画的笔形来率领上百个字根，用上百个字根率领上万个汉字，用上万个汉字率领数万条词语。
为了不同用户的需求，《郑码输入法》分为《普及型》和《标准型》两种。《标准型》重码率低，适合高速盲打输入。它不但适用于当前通用字符集的 6763 个汉字的输入，而且用同样的编码规则，在WINDOWS 2000 中，还能方便地输入大字符集的 20902 个汉字。《普及型》的编码规则简单易学，但不能用来输入大字符集汉字。《普及型》可以作为《标准型》的学习阶梯，因为二者字根的代码有共性，因此用熟练后能自然过渡到《标准型》。


术语解释

  • 笔画是汉字形体中按一定走向连续完成的一笔, 是汉字结构的最小单元。
  • 字根是汉字结构的基础单元，也称为组字部件。字根多是文字学中的独体字。
  • 基根把使用频度较高的、组字能力较强的字根选为基本字根，简称基根。基根多是规范的部首。给每个基根安排有代码。
  • 主根 起主导作用的基根，共有 50 个。 第一主根也叫“键名根”，是 50 个组字频度最高的基根，每根用 1 个英文字符作代码，形成 26 个根区。
    第二主根是一些能体现本根区副根笔形特征的主根，共有 24 个，对副根的归属起着重要作用。
  • 副根是主根以外基根的统称，多是一些大家熟悉的规范部首。
  • 形近根把一些不太常用的字根（多是符号字根）与笔形相同或相似的基根归纳在一起使用同一代码，称这些字根为形近根。
  • 区码表示基根所在根区的代码。
  • 位码表示基根在根区中所处位置的代码。
  • 取码方式取舍代码的方式。
  • 首根按照书写顺序，处于字的起笔位置的第一个基根叫首根。
  • 次根按照书写顺序，处于字的正数第二个位置的基根叫次根。
  • 次末根按照书写顺序，处于字的倒数第二个位置的基根叫次末根。
  • 末根按照书写顺序，处于字位的最后一个基根叫末根。
  • 简码只取该字（或词）常规编码中的 1 个、2 个或 3 个英文字符作为该字的简捷编码叫作该字（或词）的简码。


汉字的笔划和字根

汉字的笔画

  • 笔画是汉字形体中按一定走向连续完成的一笔，是汉字组合的最小单元。
  • 规范汉字的基本笔形是“一（横）、丨（竖）、丿（撇）、丶（点）、乙 （折）”5 种。每种基本笔形中又包含若干个变体笔形，例如“横提”归“横”，“竖钩”归“竖”。

    笔形“乙(折)又可分为“ [image] （弯）”和“ [image] （拐）”，
    其中：

    笔形“ [image] ”叫做“单弯”，笔形“ [image] ”叫做“复弯”。

    笔形“ [image] ”叫做“单拐”。笔形“ [image] ”叫做复拐。

  • 郑码用笔形作为基本字根分类排列的依据。


汉字的字根

  • 字根是汉字组合的基础单元。
  • 郑码选择构字能力强的常用字根作为基本字根，简称基根。基根多是大家熟悉的部首，这样便于汉字的分解。比如把“谢”字分解做“讠身 寸”就很自然很容易。
  • 按照笔形对基根进行分类排列，然后给每个基根安排一个英文字母作代码，形成一个基本字根集，以此作为字词编码的总纲。
  • 为兼顾大字符集的使用，在基本字根集中增加了 12 个繁体基根，它们的起笔笔形与相应的简体基根有明显差别，如“鬥、馬、車、風、龍、門”等，其它简、繁体基根，由于起笔笔形相同，归并在一起用同一代码。如：页（貝）/G 、见（見）/ L 。因此，郑码的基本字根集简繁体字通用（编码规则也是简、繁体字通用）。
  • 基根以外的其余字根统称为一般字根，简称一般根 。输入时需对一般根作变通的分解处理。就是说，把一般根分解成基根或笔画才能编码。


基本字根分类排列规律

总的规律是：按基根的第一笔笔形分类，再按前两笔或前三笔笔形分区。
举例：基根“亻、身、白、自、臼、鬼、片、隹”都属于“丿（撇）”起笔类的“丿-丨（撇-竖）”区，用代码 N 表示。因为“丿”起笔的基根在“M---R”区，其中 “丿一（撇－横）”的基根在 M 区，“丿丨（撇－竖）”的基根就在 N 区。给基根分类排列的具体做法是：

  • 选择使用频度高的、在笔形归纳方面能起主导作用的基根作为主根，其余的基根作为副根。主根共有 50 个，分为第一主根和第二主根。
  • 第一主根有 26 个，按起笔笔形分成“一、丨、丿、丶、乙”五大类。在同一类主根里再按第二笔和第三笔的笔形排列先后，形成 26 个根区，依次用英文字母的自然序命名代码，因此每个字母代表一个根区，叫做区码。
  • 某些根区再选1－2个能够体现副根前两笔或前三笔笔形特点的基根作第二主根。
  • 副根按自身的前两笔（或前三笔）笔形归并到相应的根区内。
  • 同一根区的主根和副根用同一个英文字母作区码。 郑码的基根按笔形分类排列，形成一个主根统领下，副根各在其位的检索体系。


横起笔累基根

横起笔类基根


竖起笔类基根


撇起笔类机根

撇起笔类基根


点起笔类基根


折起笔类基根


基本字根位码的确定

如果基根只用区码表示，会产生许多重码，为了减少重码，要让每个基根都有独立的代码。

  • 第一主根只用区码的 1 个字母表示，第二主根和副根都要再加 1 个位码，即用区码加位码 2 个字母表示，就象人的名字有姓有名，重名才不会多。 举例：Ｂ根区第一主根“土/B”，副根“示/BK 工/BI”，即区码均为B，位码分别为 K 和 I。
  • 区码表示基根所归属的根区，位码定出它在根区中的位置。
  • 第二主根的位码一律采用固定字符“D”。
  • 副根的位码由各副根构形中含有的主根成分或笔画成分确定，因此可用联想的办法帮助记忆。具体方法如下：
    • 按副根构形中含有的主根成分确定位码
      举例：Ｇ区的副根“页”含有O区的主根“人”的成分，因此位码定为“ O ”，即“页”的区位码是GO。同理Ｌ区的“贝/LO”，Ｕ区的“火/UO”等等。
    • 按副根构形中含有的笔画成分确定位码
      举例：Ｂ区的副根“工”含有笔画“丨／I”的成分，因此位码定为“I”，即“工”的区位码是 BI 。同理Ｃ区的“丰/CI”，Ｌ区的“巾/LI”等等。
    • 按副根构形中含有的其它副根成分确定：
      举例：副根“示、耒”都含有“小/K”的成分，所以“示/BK”、“耒/CK”。副根“骨”含有“冖/W”的成分，所以“骨/LW”，但这种情况不多。
    • 有三个副根的位码是特定的
      山 / LL 匕 / RR 己 / YY (已 / YYA 巳 / YYB)


形近根


基本字根集

基本字根集(简，繁体字通用）“（　）内是形近根”


编码规则

  • 要把汉字分解成基根才能进行编码和输入，若没有合适的基根，还需进一步分解作笔画。
  • 汉字分解成基根和笔画后，其先后顺序要按书写顺序排列。
  • 每个单字、每条词语用 1 －４个英文字母作代码，输入时不足４码的要加打空格键，字才能上屏。超过４个字母的要按取码方式加以取舍。


单字取码方式

  • 为使单字的代码不超过 4 个字母，编码时要根据单字中基根数的多少决定基根代码的取舍，这种取舍代码的方式叫取码方式。
  • 单字的取码原则是：首根的代码不能省略，是 1 取 1，是 2 取 2 。
请参阅
高频字

一基根字>

二基根字

三基根字

四基根及多基根字


词语取码方式

为使词语的代码不超过 4 个字母，编码时要根据词语中单字数 的多少决定基根代码的取舍。
给词语编码时，只需取用基根的区码。
二字词

  • 取每个字的首根和次根的区码各1码， 表述为：2 - 2
    举例：数量 ---- 米/U 女/Z 曰/K 一/A ---- UZKA
  • 第一主根作为单字参与构词，在需取 2 码时要在其代码后加“Ａ”(与作为单字用的规则一致)。高频字参与构词时，要在其代码后加“Ｖ”。
    举例：土地 ---- 土/B 地/B ---- BABV
三字词
  • 取第一字首根的1码，取第二字首根和次根各1码；取第三字首根1码组成，表述为：1 - 2 - 1。
    举例：科技馆 ---- 禾/M 扌/D 十/E 饣/O ---- MDEO
四字词和多字词
  • 取前四字的首根各1码组成，表述为：1 - 1 - 1 - 1
    举例：
    轻描淡写 ---- 车/H 扌/D 氵/V 冖/W ---- HDVW
    出污泥而不染 --- 凵/Z 氵/V 氵/V 而/G (不 氵) --- ZVVG


简码的取码方式

对一些常用字或词，按一定的规则，取其常规码中的 1－3 个字符作为简略编码，称为简码。简码对专职操作员提高输入速度大有好处，非专职操作员不必特别去记忆。

  • 一级简码：对应于 26 个高频字。
  • 二级简码用该字首根和次根各 1 码组成。
    举例：
    把 -- DY 找 -- DH 管 -- MW
    需 -- FG 取 -- CX
  • 个别常用词也有二级简码，就是取每字第一个基根的区码。
    举例：
    中国--JJ 国家--JW 一定--AW 我们--MN 政府--AT 开展--AX
    北京--TS 上海--IV 天津--AV 合作--ON 各种--RM 采取--PC
  • 三级简码
    二基根字：取第一个基根的区码和第二个基根的区位码，如：处 -- RID。
    三基根和多基根字：依次取第一、第二和第三个基根的区码，如：散 -- EQM。


关于一般根

分解汉字时，若切分出来的几个单元都是基根或笔画，只需取它们的代码就可得到字词的编码。若切分出来的单元是个没有代码的一般根，比如“辣”字，左边单元“辛”是基根代码ＳＥ，而右边单元的“束”是个没代码的一般根，此时，需对一般根作变通的分解处理RootSet，即按结构方式把它们分解成基根或笔画才能进行编码输入。
分解出的基根或笔画按书写顺序决定它们的根顺。比如“束”分解作“木、口”，由于书写时先写“木”的第一笔，因此根顺是先“木”后“口”。


一般根的结构

一般根的结构方式和分解方法

  • 按一种笔画与基根有连接关系分解，即从基根与单笔画相连处切分。
    举例：
  • 按基根与基根(或基根与笔画或笔画与笔画)相互有交叉关系分解
    举例：
  • 按一个基根内嵌有其基根的关系分解
    举例：


单体型字的分解

只有一个构字单元的字叫做单体型字。这个构字单元里可能是一个基根，也可能是一个一般根。如果是基根，则不需要分解，基根的代码就是单字的编码。如果是个一般根，则需要分解成基根或笔画才能进行编码。


合体型字的分解

由两个或两个以上构字单元组合的字叫做合体型字。合体型字又分为左右字、上下字、包围字和包孕字。
合体型字分解后，基根与笔画排列的先后顺序 -- 根顺，与先横后竖、先撇后捺、从左到右、从上到下、从外到内的一般书写顺序一致。
请参阅

  • 左右字的分解
  • 上下字的分解
  • 包围和包孕字的分解


左右字的分解

左右字分解后，基根或笔画按照从左到右的书写顺序排列先后。

举例：

树 --- 木 又 寸 滤 --- 氵 虍 心 颖 --- 匕 禾


分类

请选择主题

  • 汉字的笔画
  • 汉字的字根


代码

请选择主题

  • 编码规则
  • 横起笔类基根
  • 撇起笔类基根
  • 竖起笔类基根
  • 折起笔类基根
  • 点起笔类基根
  • 单字的取码方式
  • 简码的取码方式
  • 词语的取码方式
  • 基本字根分类排列规律


分解

请选择主题

  • 一般根的结构方式和分解方法
  • 一般根的变通处理
  • 汉字的笔画
  • 汉字的字根
  • 上下字的分解
  • 左右字的分解
  • 单体型字的分解
  • 包围和包孕字的分解
  • 单字的取码方式
  • 合体型字的分解


分解原则

请选择主题

  • 一般根的结构方式和分解方法
  • 一般根的变通处理


点起笔类

请选择主题

  • 汉字的笔画
  • 汉字的字根
  • 横起笔类基根
  • 撇起笔类基根
  • 竖起笔类基根
  • 折起笔类基根
  • 点起笔类基根
  • 基本字根基
  • 基本字根分类排列规律


上下字的分解

上下字分解后，基根或笔画按照从上到下的书写顺序排列先后。

举例：

基 --- 其 土 索 --- 十 冖 糸
警 --- 艹 勹 口 攵 言


次根

请选择主题

  • 简码的取码方式
  • 词语的取码方式
  • 单码的取码方式


词语

请选择主题

  • 编码规则
  • 词语的取码方式


根顺

请选择主题

  • 上下字的分解
  • 左右字的分解


第二主根

请选择主题

  • 基本字根集
  • 横起笔类基根
  • 撇起笔类基根
  • 竖起笔类基根
  • 折起笔类基根
  • 点起笔类基根
  • 单字的取码方式
  • 基本字根分类排列规则
  • 基本字根位码确定


笔画

请选择主题

  • 编码规则
  • 汉字的笔画
  • 汉字的字根
  • 横起笔类基根
  • 撇起笔类基根
  • 竖起笔类基根
  • 折起笔类基根
  • 点起笔类基根
  • 上下字的分解
  • 左右字的分解
  • 单体型字的分解
  • 包围和包孕字的分解
  • 单字的取码方式
  • 基本字根分类排列规律
  • 基本字根位码的确定


笔顺

请选择主题

  • 上下字的分解
  • 左右字的分解
  • 单体型字的分解
  • 包围和包孕字的分解


笔画说明

请选择主题

  • 汉字的笔画
  • 汉字的字根


笔形

请选择主题

  • 汉字的笔画
  • 汉字的字根
  • 横起笔类基根
  • 撇起笔类基根
  • 竖起笔类基根
  • 折起笔类基根
  • 形近根
  • 基本字根分类排列规律


包围和包孕字的分解

  • 按从上到下的顺序分解。就是说，把起包围作用和起上包孕、左上包孕以及右上包孕作用的基根视为上，把被包围(或被包孕)的基根视为下。对下包孕字，要把被包孕的基根视为上，把起下包孕作用的基根视为下
  • 按从左到右的顺序分解。就是说把起左包孕和左下包孕作用的基根视为左，把被包孕的基根视为右。


二基根字

请选择主题

  • 单字的取码方式
  • 简码的取码方式


单字

请选择主题

  • 编码规则
  • 单字的取码方式